Introduce yourself here! In order to avoid spam, new users must first comment on the discussion in the 'Introductions' before they become 'full members'
Options setting problem
  • I try to translat to Traditional Chinese, after upload all the files, when I want to set the Language option in Options-International settings but
    there was only [English (US)] only, What can I do?
  • Did you download a language pack from the Flatpress Wiki and insert it into your Flatpress installation? Or did you make your own language pack files?
  • Also, note that every language file must be saved with "UTF-8 without BOM" encoding!
  • I download the German one form Flatpress Wiki and change to Traditional Chinese, also try make my own one, the result was the same. Anything I have to do to tell the system about my new language pack.

    Sorry I don't know what in "without BOM", pls told me. thanks a lot
  • UTF-8 without BOM (Byte Order Mark) is an encoding, just like UTF-8. The BOM is a whitespace character which is automatically added at the start of UTF-8 encoded files: the problem is that it causes PHP to start doing output, so it's better if there's no whitespace!

    Most text editor allow you to save your files with that encoding... Look in the menus, there must an option to do that (and if there's not one, I suggest you to use an editor that has that!) :)
  • Thanks, I use Notepad++ to edit the Language files, there was no whitespace character find while the files upload to the server.
    FlatPress work find only it still show english system messages, look like nothing added in.
  • I check again all files it was UTF8 without BOM. And it show the Chinese character if I just overwrite the original file. Any other idea? :-(
  • check the file permissions of the files you uploaded.

    the dir containing the lang files should be called something like zh-cn

    that dir should contain a lang.conf.php file with the following:

    <?php

    $langconf = array();
    $langconf['id'] = 'Chinese (CN)';
    $langconf['locale'] = 'zh-cn';
    $langconf['charsets'][0] = 'utf-8';

    ?>
  • Thanks, it works, I put line 3 'Chinese' in Chinese character.
  • Posted By: ViViThanks, it works, I put line 3 'Chinese' in Chinese character.


    sure that's fine as well :)
This discussion has been closed.
All Discussions
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion