Introduce yourself here! In order to avoid spam, new users must first comment on the discussion in the 'Introductions' before they become 'full members'
[ita] html si, html no
  • Essendo ormai da anni abituato ad usare html, mi trovo piuttosto spaesato con BBCode.
    Veniamo al problema:
    Se disattivo il plugin BBcode e scrivo un post in html questo non viene formattato e continuo a vedere i segni di maggiore e minore che contengono il tag.
    Nelle pagine statiche invece l'html viene interpretato senza problemi (tranne che nell'anteprima).
    Con BBCode attivo (sempre nelle pagine statiche) i due codici coabitano tranquillamente.
    Quindi volevo sapere:
    1) e' possibile far coabitare BBcode e html nei post senza usare [html] ... [/html]?
    2) in alternativa e' possibile usare solo html "interpretato"?

    grazie anticipate
  • ottima domanda, grazie per averlo fatto notare, direi che quello che indichi
  • ho applicato le modifiche, ma il problema persiste
    l'html non viene MAI interpretato, ne' con bbcode attivo ne' con bbcode disattivo.

    se puo' esserti d'aiuto ti sottolineo nuovamente il fatto che con le pagine statiche non c'e' nessun problema (tranne, come t'ho gia' detto nell'anteprima)
  • Ho dimenticato di dire che la soluzione che ti ho indicato NON ha valenza retroattiva! Il motivo
  • ti do qualche aggiornamento...
    ti premetto che per fare i test sono passato a "leggero"

    dopo aver modificato il file:

    se scrivo un nuovo post con bbcode attivo in html i tag sono visibili, quindi non formattati
    se scrivo un nuovo post con bbcode inattivo in html i tag non sono visibili, quindi formattati

    in pratica i 2 codici non coabitano
    in piu' riattivando nuovamente bbcode alcuni vecchi post sono formattati altri no...
    un casino pazzesco ;)

    secondo me l'ideale e' che i post si comportino come le statiche (anche se tu lo chiami bug, io lo chiamo una figata!!!)


    EDIT:
    dico la mia:
    andrebbe "semplicemente" tolta la funzione che converte < e > in < e in >
    dimmi in che file l'hai nascosta che provo a vedere
  • in pratica i 2 codici non coabitano


    cio
  • add_filter('comment_save_pre', 'wp_specialchars'); --> non esiste!!!

    comunque commentanto add_filter('content_save_pre', 'wp_specialchars'); FUNZIONA!

    ti faccio vedere come salva i file adesso:

    VERSION|fp-0.703.5|SUBJECT|prova|CONTENT|html
    [b]bbcode[/b]|AUTHOR|tojo72|DATE|1191061356|

    adesso con bbcode attivo i tag html vengono salvati con < e > quindi vengono poi formattati correttamente a video

    questa e' classe!!!
    chiedi... e l'autore ti risponde e risolve il problema!!!

    non sono un grande esperto di php (faccio piccoli e semplici script... nulla di piu'), ma per collaborare al progetto se ti serve una "cavia" per nuovi test sono disponibile.

  • add_filter('comment_save_pre', 'wp_specialchars'); --> non esiste!!!


    ieri ero tornato dopo una giornatina allucinante quindi non sono stato tanto a cercare :P
    comunque quella fa l'escape nei commenti, ora che ci penso
This discussion has been closed.
All Discussions
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion