November 2018: Registration is broken at the moment - we are working on it. Sorry for the inconvenience!
Check the blog for the latest news about the ongoing FlatPress revival!
favicon problem??
  • hi there, i can't seem to get the favicon in my blog working... normally there is one preinstalled, isn't there? however i chaged some properties in my css and now there is no favicon... i tried to download the whole flatpress blog-package again and overwrote the folder favicon in fp-plugins.. but it isn't working..due to what???

    i already did a few html pages and when embed a favicon i usually do it this way:
    <link rel="shortcut icon" href="favicon.ico" >
    <link rel="icon" href="favicon.gif" type="image/gif" >

    when i preview the sourcecode of my blog in my browser there is a line which says:

    <link rel="shortcut icon" href="; />

    but exactly at that place on the server i can find the fplogo.gif!! and it's even the original it can't be to big or anything..

    does anybody know how i can change that or possibly add the lines mentioned above to the index.php!!!
  • Posted By: mathiregisterhowever i chaged some properties in my css and now there is no favicon.

    Hm, try this:

    - clear cache
    - change the used theme to any other and try again

    Then disable the favicon plugin and reload (browser reload) the blog. If nothing will appear, acivate the plugin again, clear cache and cookies in the browser and reload (browser reload) your blog again.

    Please tell what happen...
  • Maybe this could help?

    I am about to use this myself.
  • So I was about to use that link I just posted, when I realized there is already a favicon folder in the plugins folder of the new flatpress release.
    So your best option is probably just to upgrade.. It's fairly straightforward from there.

    Plugin Name: FavIcon
    Plugin URI:
    Description: Adds a favicon to FlatPress
    Author: NoWhereMan
    Version: 1.0
    Author URI:

    function plugin_favicon_head() {
    echo '<link rel="shortcut icon" href="' . plugin_geturl('favicon') .'imgs/favicon.ico" />';

    add_action('wp_head', 'plugin_favicon_head');


    Just modify that imgs/ path to lead to your favicon (aka change the part after it to the name of the file you put in).
    I changed mine to favicon.ico (as above) to cover all my bases on all the browsers.
    If you still have any problems, just clear your cache.
  • thanks to all, it's working
  • I was also having a problem with the favicon today. This is how I got it to work. I use Favicon Picker 2. I went in and blanked the icon and then reset it. Voila. Fixed and now pointing to my custom icon.
  • Not quite there yet. It works for the root folder and the entries links but the FP icon returns when a specific entry is accessed with this in the URL - ?x=entry:entry

    What am missing here?

    [edit]OK, it seems that each page that had previously displayed the FP favicon needs to be repaired separately.[/edit]
  • if Favicon Picker is the ffox extension, it will only "fix" your client side, and not the FP site; the favicon plugin is a bit broken in 0.909.1, try and download the SVN version.
  • If you want configure the favicon from the Admin Panel you can use my version of plugin favicon:
  • The favicon seems to be working OK in Opera and Galeon. I think FF was confused because of how data is stored in those stupid sqlite files. Clearing the data via Favicon Picker fixed FF. Keeping fingers crossed . . .
  • Have downloaded the plugin and will get to it shortly.
  • Try to check the size of your favicon you can check through this wiki page like what i did to my blogs and site Nasal Irrigator
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion