November 2018: Registration is broken at the moment - we are working on it. Sorry for the inconvenience!
Check the blog for the latest news about the ongoing FlatPress revival!
install flatpress 1.0.3 on a new webserver - maybe a php problem i have... PHP Version 7.1.10
  • Happy GNU Year @all

    i will set up a fresh 1.0.3 on a webserver whit php 7.1.10

    my error msg is:
    [Thu Jan 04 13:11:05.394319 2018] [proxy_fcgi:error] [pid 20370:tid 139722223462144] [client 78.55.231.32:53310] AH01071: Got error 'Primary script unknown\n'
    [Thu Jan 04 13:11:39.671735 2018] [proxy_fcgi:error] [pid 20329:tid 139722324174592] [client 78.55.231.32:53338] AH01071: Got error 'Primary script unknown\n'
    [Thu Jan 04 13:39:31.197581 2018] [proxy_fcgi:error] [pid 22542:tid 139722324174592] [client 78.55.231.32:53488] AH01071: Got error 'PHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; widget_indexer has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.widgets.php on line 9\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; comment_indexer has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.comment.php on line 3\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; entry_cached_index has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.entry.php on line 3\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; entry_index has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.entry.php on line 36\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; entry_archives has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.entry.php on line 226\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; draft_indexer has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.draft.php on line 6\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; FPDB_QueryParams has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.fpdb.class.php on line 3\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; FPDB_Query has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.fpdb.class.php on line 136\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; FPDB_CommentList has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.fpdb.class.php on line 591\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; FPDB has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.fpdb.class.php on line 637\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; FPDB_transaction has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.fpdb.class.php on line 765\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; plugin_indexer has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/core/core.plugins.php on line 6\nPHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; SmartyValidate has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/smarty/SmartyValidate.class.php on line 33\n'
    [Thu Jan 04 13:40:25.455555 2018] [proxy_fcgi:error] [pid 21838:tid 139722248640256] [client 78.55.231.32:53494] AH01071: Got error 'PHP message: PHP Deprecated:  Methods with the same name as their class will not be constructors in a future version of PHP; Smarty_Compiler has a deprecated constructor in /var/www/myside.tld/htdocs/fp-includes/smarty/Smarty_Compiler.class.php on line 35\nPHP message: PHP Warning:  preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /var/www/myside.tld/htdocs/fp-includes/smarty/Smarty_Compiler.class.php on line 270\n', referer: http://myside.tld/setup.php
    [Thu Jan 04 13:41:25.316032 2018] [proxy_fcgi:error] [pid 22542:tid 139722164713216] [client 78.55.231.32:36138] AH01071: Got error 'PHP message: PHP Warning:  preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /var/www/myside.tld/htdocs/fp-includes/smarty/Smarty_Compiler.class.php on line 270\n'
    [Thu Jan 04 14:12:09.490731 2018] [proxy_fcgi:error] [pid 20370:tid 139722164713216] [client 78.55.231.32:53710] AH01071: Got error 'Primary script unknown\n'


    what can i do to install fp on this server? thanks in advanced

  • hi,

    sorry for being quite late on this topic. 
    FlatPress is now running successfully under PHP7, please see my announcement: http://flatpress.org/vanilla2/discussion/comment/11543

    Regards,
    Arvid
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion