Introduce yourself here! In order to avoid spam, new users must first comment on the discussion in the 'Introductions' before they become 'full members'
Upgrade Smarty to work with php 5.5?
  • I want to upgrade to php 5.5 so I can run an owncloud instance along with my Flatpress. To do so, I need php 5.5 but smarty "brokes" when i change the php version - or that is what I think happens. Any ideas on how to resolve this?
  • We have the same problem. 
  • same here :( i need a fix asap.
  • Any error messages you can paste here? I suppose we will all hit this problem sooner or later, if we want to keep using FlatPress.

    Maybe we can work through it?

  • You can download the Patch for Flatpress 1.0.3 version or Flatpress Github 402 version here:

    Please note:

    Use this patch at your own risk!
    This Flatpress Patch version works only up to the PHP 5.6 version and doesn't work with PHP 7.x or higher.
    See PHP supported Versions (lifecycle): http://php.net/supported-versions.php
  • @labotix thank you! so it's time for a change.

    i'll take this little time slot (php 5.6 support ends in december 2018) to switch to another software and for me also a different kind of blog, maybe koken or something like this.
  • Hi,

    I'm sorry, my patch version posted on January 29, 2107 have a problem with the categories. It's now fixed in this version:


  • Hello @laborix. I'm not so expert.

    I have FP 1.0.3 after the change on www.musicletter.it/tracks (just for try it on secondary blog)
    /fp-includes/smarty/Smart_Compiler.class.php
    /fp-includes/smarty/SmartyValidate.class.php
    /fp-includes/core/core.fpdb.class.php
    /fp-includes/smarty/plugins/function.list_categories.php
    login.php

    I have that error 
    image

    Can you help me?




    ps
    Is there risk? I mean, once UPDATED and if does not work, I can turn back without losing anything?

  • yes, you can go back if you have the old files without any problems.

    I will see what I can do the next days to fix this Strict Standards warning. If finished I do update the patch pack for downloading. You get a posting here.



  • The Strict Standard PHP error can be from a wrong bbcode plugin version in your track blog. I get this error too if I import my Flatpress blog of the year 2012 with all plugins.

    But replacing the bbcode plugin with the current Flatpress 1.0.3 version plugin solves this issue.

    I have updated my patch file list, so you can test an possible update or build in an other subdirectory a clean setup to try out the patches.

    No matter what way you take, please make a complete backup of your blogs beforehand.

    regards
    Laborix  

  • First all thanks to use your time to help me.

    So I have to replace the updated file (as per your indication above) and also the bbcode updated FP 1.0.3 plugins (\ fp-plugins \ bbcode \ plugin.bbcode.php). It's right?

    To recap:

    1) Patch php 5.6
    /fp-includes/smarty/Smart_Compiler.class.php
    /fp-includes/smarty/SmartyValidate.class.php
    /fp-includes/core/core.fpdb.class.php
    /fp-includes/smarty/plugins/function.list_categories.php
    login.php

    2) bbcode FP 1.0.3
    Simply replace just one file? \FP-plugins\bbcode\plugin.bbcode.php

    Waiting for reply
  • Please, update the whole bbcode Plugin-Directory from a new Flatpress 1.0.3 download.

    Next step, please, download the patch file I posted above. There are now a few more files that needed to be replaced, especially if you use the PrettyUrls plugin.

    I tested this patches on a old blog of me with more the 400 entries, it should work also for you.


    regards
    Laborix
  • After a few headaches, thanks to your valuable advice, I managed to upgrade PHP main and secondary blog. 

    Your help was 5 stars!

    Thanks again for the support.
  • I'm glad, have a nice time.

    regards
    Laborix
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion