Introduce yourself here! In order to avoid spam, new users must first comment on the discussion in the 'Introductions' before they become 'full members'
FlatPress 1.0 Solenne
  • Which are the changes in this last version ?
    I've 2 websites with flatpress.......so, it's possible to update last version of flatpress without use all file .zip ?
    If it's possible to modify only 2-3 files, I can make it directly without doing all procedure.
    Thanks

  • The following files changed since last major version (0.1010.0):

    /fp-includes/core/core.system.php
    /fp-includes/core/core.filesystem.php
    /fp-includes/core/core.theme.php
    /fp-plugins/lastentries/plugin.lastentries.php
    /fp-includes/core/core.wp-formatting.php
    /fp-plugins/akismet/plugin.akismet.php
    /fp-plugins/thumb/plugin.thumb.php
    /fp-plugins/bbcode/Artistic.clarified
    /fp-plugins/bbcode/ChangeLog
    /fp-plugins/bbcode/copying
    /fp-plugins/bbcode/inc/stringparser.class.php
    /fp-plugins/bbcode/inc/stringparser_bbcode.class.php
    /fp-plugins/bbcode/license
    /fp-plugins/bbcode/thanks
    /fp-includes/core/core.fileio.php
    /fp-includes/core/core.utils.php
    /defaults.php
    /fp-plugins/blockparser/lang/lang.it-it.php
    /fp-interface/sharedtpls/comment-form.tpl
    /fp-plugins/prettyurls/plugin.prettyurls.php
    /admin/panels/entry/admin.entry.write.tpl
    /admin/panels/static/admin.static.write.tpl
    /admin/panels/widgets/admin.widgets.js
    /fp-plugins/jquery/plugin.jquery.php
    /fp-plugins/jquery/res/jquery-ui-1.8.11.custom.min.js
    /fp-plugins/jquery/res/jquery-ui-1.8.2.custom.min.js
    /fp-plugins/jquery/res/jquery-1.5.2.min.js
    /fp-plugins/jquery/res/jquery-1.4.2.min.js
    /fp-includes/smarty/Config_File.class.php
    /fp-includes/smarty/Smarty.class.php
    /fp-includes/smarty/Smarty_Compiler.class.php
    /fp-includes/smarty/internals/core.process_compiled_include.php
    /fp-includes/smarty/internals/core.write_cache_file.php
    /fp-includes/smarty/plugins/compiler.assign.php
    /fp-includes/smarty/plugins/function.math.php
    /fp-includes/smarty/plugins/modifier.regex_replace.php
    /fp-includes/smarty/plugins/outputfilter.trimwhitespace.php
    /fp-plugins/prettyurls/tpls/admin.plugin.prettyurls.tpl
    /fp-plugins/prettyurls/lang/lang.en-us.php
    /fp-includes/core/core.users.php
    /admin/panels/entry/admin.entry.commentlist.tpl
    /admin/panels/maintain/admin.maintain.php


    there were no major changes involved, though. I think you could even just overwrite the old files with those in the new package.
  • I nomi che dai alle versioni di flatpress sono troppo forti. Per l'ennesima volta complimentoni.
  • Scusate ma ho riscontrato un errore.
    Ho installato per intero la nuova versione di flatpress. Cioè ho cancellato tutto quello vecchio e messo quello nuovo. Ho ricaricato la cartella content. Ricostruito l'indice. Funziona ma non mi mostra il contentuto ne delle statiche, ne dei post. Mostra soltanto i titoli. Dove è il problema? grazie
  • potrebbe essere un problema di permessi.. prova ad eseguire il "restore" dei permessi dal pannello admin. Controlla anche di avere attivi i giusti plugin e che il tema sia compatibile.

    EDIT: vedo però che i commenti funzionano... uhm...attiva l'error_reporting; ho aggiornato bbcode, quindi prova a controllare che versione di PHP stai usando
  • PHP4 Ho paura...
  • Impostando php5.2 ho risolto il problema. Grazie mille per la tempestività ;)
  • Well done!
    So do you feel that Flatpress is ready for a stable version?

    However comments on the blog don't work: there's an error in the Akismet plugin.

    You could also have updated jQuery ;-)
    The last stable is the 1.7.1.
  • So do you feel that Flatpress is ready for a stable version?
    I suppose we can consider it stable

    You could also have updated jQuery ;-)
    uhm. next minor? ;)
    edit: now in SVN
  • Upgrading file for file at the end I wasn't sure.......so I've upgraded all, without any problems, except for an error on file /fp-includes/core/core.utils.php    I've replaced it with old file I had before and now it is ok.
  • what kind of error?
  • So, I've to retify...........the error appears only going on Administration Area, Mantain, Check for updates, this is what appears above:


    Notice: curl extension is not installed in /home/mhd-01/www.warsintheworld.com/htdocs/fp-includes/core/core.utils.php on line 408

    The wrong file is of 1174 kb, while that good (or at least works for me) is big 10804 kb.
  • that's because libcurl is disabled on your host. You can safely ignore that.
  • Is libcurl disabled on all hosts? And how can I check that?

    thanks
  • if the update check functionality in the maintenance panel works, then it is not disabled. You can also read the PHP info page on the same panel. btw, it is only used for the update check, so even if libcurl is missing, you don't have to worry about it
  • Grazie mille NWM !!!
    Ho installato la nuova versione solo oggi, e sembra girare bene... ma questa ormai non è più una novità!
    Grande!
  • wow i am not sure about spanish or portugese
  • Is there still progress on flatpress?

     

  • Flatpress 1.0 Solenne doesn't work with php 5.5!!!!
  • Hi, what's the problem?
    Maybe it's better if you open a new thread...
  • Just moved to new hosting and the comments are not working. I'm receiving the notification e-mail, a comment [number].txt file is being created but it is blank. and comments on the post page are blank.

    All folders under fp-content are 0777 comment[number].txt files are 0666

    Any idea where I should start.

    Cheers.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion