Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorNoWhereMan
    • CommentTimeFeb 16th 2010 edited
     permalink
    suppress errors with the error_reporting(E_ALL &~ E_NOTICE &~E_STRICT); directive

    to upload images (that's what upload is mainly intended for), just add an image to your post

    HTH
    •  
      CommentAuthorStanley
    • CommentTimeFeb 16th 2010
     permalink
    Posted By: NoWhereManto upload images (that's what upload is mainly intended for), just add an image to your post


    Oh, you mean just set WLW to publish pictures to my blog rather than by FTP? That would be good. I tried it very quickly with the errors thing added to my defaults.php, but I still got an error :(

    Let me try it with a fresh installation and report back. I suspect I'm not giving it a fair chance with my own blog the way it is.
    •  
      CommentAuthorStanley
    • CommentTimeFeb 16th 2010 edited
     permalink
    Hey!! It worked!

    Fresh install of FP 0.909.1 plus the new version of the plugin = just plain easy

    Didn't need to add anything to the defaults file and no messing around setting up the FTP side of things - just insert or paste an image, click publish and... KERCHOWWW! It's up there.

    The awesomeness continues - thanks!

    It does create a rather long file name though, which makes the drop down selector quite wide in the control panel editor. I noticed it added "windowslivewriter" to the start of the file name, followed by a sanitised version of the blog post title. Anything can be done to shorten that? One of my image file names was already quite long, so the drop down selector stretched over half the screen width (only when selected - not in it's collapsed state on the toolbar)

    example:

    windowslivewriterthisisatestimageuploadedtoblog_11cbbneed_for_speed_underground_2_2.jpg
    •  
      CommentAuthorNoWhereMan
    • CommentTimeFeb 16th 2010
     permalink
    1) choose shorter names :D in my small tests it didn't prepend any text, though; strange...
    2) the bbcode dropdown sucks monkey balls and it should be definitely redesigned... but who's got the time? :(

    personally I don't even use the bbcode toolbar anymore and I just disable it from the config panel, I just remember the file name.

    I've still not settled on using WLW because I don't like it will spread pure HTML in my posts and even probably some hardcoded URLs for images :/

    PS: remember you can use the editing function in WLW too!
    •  
      CommentAuthorStanley
    • CommentTimeFeb 19th 2010 edited
     permalink
    A word of warning that although this seems to work well with a fresh install of FP 0909.1 I've hit a problem using it on existing blogs where (rightly or wrongly) I just overwrote the existing plugin. I now can't post pictures (even by FTP) on blogs where once I could. I've tried disabling and reenabling the plugin, but it won't disable (?). You click the disable link and it still comes back like it's enabled. I tried pasting the following link and just changing the disable to enable but I got an error message (a Flatpress one-liner "We apologize, an error occurred." - not a server error). Maybe it's to do with the number on the end?
    http://www.mybl.og/admin.php?p=plugin&action=default&disable=remoteposting&_wpnonce=30818a69dc
    I've tried deleting the plugin to remove it from my list but when I copy it back into place it comes straight back up in the list as being enabled, and I can't disable it again.

    Maybe the "trick" is to first disable the original plugin (then maybe delete the thing entirely) and then install and enable the new version. I'll try that on another blog and see what happens, but it must be registered somewhere even though I delete it. Any ideas how I can de-register it so my blog makes like it's never even heard of the remoteposting plugin, so I can install the latest version afresh?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeFeb 20th 2010 edited
     permalink
    it might be a problem with cookies, did you try to logout and login back? (unrelated to this plugin)
    •  
      CommentAuthorStanley
    • CommentTimeFeb 23rd 2010
     permalink
    Posted By: NoWhereManit might be a problem with cookies


    I tried that - it might be a problem with some other things I'm trying to do, so it might be specific to me.

    I've since installed it successfully on a couple of other blogs but I went through the process of disabling then deleting the original plugin, deleting the cache, re-indexing, then displaying the list of plugins again (to make sure it was gone) before copying over the new version and enabling it.

    Once installed it works great - haven't had any problems with it.

    Regarding the prepending of the image file name with "windowslivewriter", this also gets added to attachment names (I use the attach zip file plug-in for WLW), which get filed in attachs. Maybe it's something which WLW is adding.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeFeb 23rd 2010 edited
     permalink
    Posted By: StanleyMaybe it's something which WLW is adding.


    I guess so, no prepending is done on the FP side
    •  
      CommentAuthorbosh
    • CommentTimeMay 3rd 2010 edited
     permalink
    Im trying to autopost using posterous - but when I use the wordpress blog (metaweblog api) autopost add function, it returns an error

    We were not able to authenticate this account. Reason: We could not find a valid endpoint


    What can I do? Any ideas?
    •  
      CommentAuthorbosh
    • CommentTimeMay 3rd 2010 edited
     permalink
    I tried giving the full url to the xmlrpc file:

    http://mysite.com/fp-plugins/remoteposting/inc/xmlrpc.php, which allowed posterous to accept the settings, but, when I click on the link to my flatpress autopst icon from posterous (off the front page) now i get :
    Fatal error: Class 'IXR_Server' not found in /homepages/2/d108111940/htdocs/blog/fp-plugins/remoteposting/inc/xmlrpc.php on line 120


    mmm, Ive read elsewhere i should place an rsd file in the homepage, Im presuming this isnt necessary because of the plugin....or is this something to do with php versions on the server?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 3rd 2010 edited
     permalink
    the endpoint is http://mysite.com/?xmlrpc
    •  
      CommentAuthorStanley
    • CommentTimeMay 3rd 2010
     permalink
    Interesting service. I just signed up and followed what you said you did, including giving the full url to the xmlrpc file to get it to accept the settings. I tried a test post which (it says) went through ok, but it's not on my fp blogs and when I click on the autopost "blog" icon it just points to my blog's fp-plugins/remoteposting/inc/xmlrpc.php file, which just results in a blank page (I tried this in both Opera and Chrome, in case one was suppressing a useful error message).

    I've e-mailed them and pointed them to this thread, to see if they can help. Hope so.
    •  
      CommentAuthorStanley
    • CommentTimeMay 3rd 2010 edited
     permalink
    Posted By: NoWhereManthe endpoint ishttp://mysite.com/?xmlrpc


    I tried that one already, but posterous doesn't like it.

    edit: I just tried ?xmlrpc again. The error message is throws up is "We were not able to authenticate this account. Reason: We could not find a valid endpoint"
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 3rd 2010
     permalink
    •  
      CommentAuthorStanley
    • CommentTimeMay 3rd 2010
     permalink
    Posted By: NoWhereMando you have the last version of the plugin installed?


    Yes, I just downloaded that one and checked it line by line with the version I had. It's identical.
    •  
      CommentAuthorbosh
    • CommentTimeMay 3rd 2010
     permalink
    thanks Stanley and NoWhereMan - looks like you got exaclty what i got Stanley, though I didnt get the blank page, I got the error message. Posterous is usually very good at this - but I did need to do some other wibbly stuff to get another wordpress (multiuser) account to work. That needed the full url to the xmlrpc file. But it did work - this doesnt, as Stanley says, posterous says it has gone through, but nothing shows up on FP. Im going to try the other RSD file and see what happens, but I dont think that'll work either....
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 3rd 2010
     permalink
    the rsd file is at http://mysite.com/?xmlrpc&rsd
    •  
      CommentAuthorStanley
    • CommentTimeMay 4th 2010 edited
     permalink
    Posted By: NoWhereManthe rsd file is athttp://mysite.com/?xmlrpc&rsd


    Well, that seemed to be accepted instead of putting the path to the xmlrpc.php file, and when you click on the blog icon in the Posterous management console it now brings up my blog. Unfortunately the post still doesn't show up.

    I haven't had a reply from Posterous yet.

    edit: actually I screwed it up and entered http://www.mysite.xxx/?xmlrpc.php&rsd - note the ".php" I left in there by mistake. It seemed to like it though - my blog title showed up in the Posterous admin page and going to that address brings my blog up in my browser.

    Unfortunately when I typed it properly it came up with an error when I tried to save it.

    I also tried creating an rsd.xml file and putting it in blog root folder, altering the relevant path in my remoteposting plugin file, and just about every other combination I could think of.

    No luck :(
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 4th 2010 edited
     permalink
    have you tried to suppress every possible warning?
    open defaults.php and remove the leading #'s from the last two lines (those with the _dummy text)
    •  
      CommentAuthorbosh
    • CommentTimeMay 5th 2010
     permalink
    great testing Stanley - Ill look at these options again today....but, NoWhereMan, Im already supressing the dummy error code at the bottom of defaults.php because I was getting an error page when I tested posting comments).

    Im wondering if this is to do with something 'other' server side - versions of php or something I can adjust using htaccess??

    Id really like to get this to work as Im doing a 'business on the web' type seminar next week and want to demo just how good a solution Flatpress can be for those on a lower budget, and to use in a social media context...so, any further help is really appreciated!
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 5th 2010
     permalink
    mmm, well, you guys (either you or stanley) could try to enable logging and see if there is something relevant.

    here's how to: open inc/xmlrpc.php scroll down to function logIO and set

    $xmlrpc_logging=1;

    just to be sure, change this line as well

    $fp = fopen("xmlrpc.log","a+");


    $fp = fopen(FP_CONTENT."xmlrpc.log","a+");

    you should now be able to find xmlrpc.log at fp-content/xmlrpc.log , see if it contains anything relevant;
    also if the posterous service allows you to choose which blog API to use, try choosing MetaWebLog instead of WordPress, since only a subset of the WP API is implemented.

    HTH
    •  
      CommentAuthorbosh
    • CommentTimeMay 5th 2010 edited
     permalink
    this is what displays in the browser window when I post off Posterous, and navigate to the log page http://mysite.com/fp-content/xmlrpc.log

    2010-05-05 10:15:43 Input:

    2010-05-05 10:17:05 Input:
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 5th 2010
     permalink
    that .log displays XML as well (which is probably eaten by your browser), either download it or open the source window from withing your browser
    •  
      CommentAuthorbosh
    • CommentTimeMay 5th 2010 edited
     permalink
    mmm

    If I download the file, it says the same thing (nothing else) as above...If I 'view selection source' (in FF) I get
    <pre>

    2010-05-05 10:15:43 Input:

    2010-05-05 10:17:05 Input: </pre>

    but thats all I get
    •  
      CommentAuthorStanley
    • CommentTimeMay 6th 2010
     permalink
    Posted By: NoWhereManyou should now be able to find xmlrpc.log at fp-content/xmlrpc.log , see if it contains anything relevant;
    also if the posterous service allows you to choose which blog API to use, try choosing MetaWebLog instead of WordPress, since only a subset of the WP API is implemented.


    I tried this but I can't find a log file after any of my several test posts.

    I received a reply from Posterous this morning - I just gave them my blog address and the link to this thread. Hopefully they can help.

    I decided to make a fresh start on another FP blog, and this is the log of what I've tried today:

    Test 1) using rsd.xml file in blog root and changed path to rsd file in remoteposting plugin
    Test 2) as test 1 but altered path in rsd file to point directly at the xmlrpc.php file
    Test 3) as test 2 but error handler enabled in defaults.php and log file enabled in xmlrpc.php
    Test 4) tried to cheat my way past the Posterous "can't find end point" error by using "/?xmlrpc.php&rsd" in my autopost setting instead of the direct link to the php file, or just the FP default which is "/?xmlrpc&rsd"
    Test 5) typed the absolute path to the rsd.xml file in the remote posting plugin
    Test 6) wrote the direct path to the xmlrpc.php file in Posterous
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 6th 2010
     permalink
    the endpoint must be /?xmlrpc , with the others you are guaranteed it won't work :p
    that said, I don't know at the moment what the problem is, I'm sorry I can't investigate further now :/
    •  
      CommentAuthorStanley
    • CommentTimeMay 6th 2010
     permalink
    Posted By: NoWhereManthe endpoint must be /?xmlrpc


    I know, I saw you stressed that much earlier in this same thread when I was first starting out using the plugin. I actually wrote back to Posterous and suggested that the problem might simply be that their autopost setup script is programmed only to accept an address with ".php" in it, as I inadvertently discovered when I accidentally wrote myblog.com/?xmlrpc.php which their system accepted, though it was clearly wrong.

    I've asked them if they can look at their script to see if they can get it to accept just /?xmlrpc on it's own - it might actually work, but their script won't let us enter it like that.

    Let's see if they respond - if not then Posterous is no use to me.
    •  
      CommentAuthorStanley
    • CommentTimeMay 6th 2010
     permalink
    WOW! Breakthrough - I did it!

    Don't quite know how yet - I need to look at what all my current settings are then see if I can try this on another blog. Maybe they changed something at their end? Seems strange that it suddenly posted something.

    I just did another post to see if was a fluke, this time by attaching an oversized image - it resized it ok, in both my Posterous blog and my FP one and, in both cases, it was linked to a larger version which popped up very quickly in an overlay, which closed again when I clicked on the picture. It seemed to work very smoothly - better than the lightbox version I'm used to with FP, I have to say.

    Posting by e-mail - now, there's something to play with.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 7th 2010
     permalink
    very nice :) the cool thing is you can now even post by MMS using your cell phone, since MMS can be sent to email addresses
    •  
      CommentAuthorStanley
    • CommentTimeMay 7th 2010 edited
     permalink
    Ok - I took a while there, sorry, but I wanted to test what was the minimum number of changes you need to make to get Posterous to post to FlatPress. Here goes!

    This worked for me with the remote posting plugin version 1.4 - untested in v1.3

    PLEASE BEAR IN MIND - I have no idea what effect this will have on your ability to post remotely using things like Windows Live Writer - I haven't got time to test that just now. Try this at your own peril.

    You need to do steps 1 to 3 first, before attempting to set up your autopost blog setting in Posterous (see step 4)

    In all of the code below you need to replace "yourdomain/yourflatpressfolder" with your domain name and folder (if you have one) where FlatPress is installed.

    1) Create a new text file with just the following in it, then save it as rsd.xml in your blog root


    <rsd version="1.0" xmlns="http://archipelago.phrasewise.com/rsd">
    <service>
    <engineName>FlatPress</engineName>
    <engineLink>http://www.flatpress.org/</engineLink>
    <homePageLink>
    http://yourdomain/yourflatpressfolder/
    </homePageLink>
    <apis>
    <api name="MetaWeblog" preferred="true"
    apiLink="http://yourdomain/yourflatpressfolder/?xmlrpc"
    blogID="1" />
    </apis>
    </service>
    </rsd>


    2) Open up plugin.remoteposting.php and alter line 15 to show the absolute path of your rsd.xml file - i.e. so it reads something like as follows:

    echo '<link rel="EditURI" type="application/rsd+xml"
    title="RSD" href="http://yourdomain/yourflatpressfolder/rsd.xml" />


    Edit: no need to do the above, just replace the end of the line so it reads rsd.xml, as follows:

    echo '<link rel="EditURI" type="application/rsd+xml"
    title="RSD" href="'.BLOG_BASEURL.'rsd.xml" />


    3) Open up defaults.php and removed the "#" from the start of the last 2 lines so they read:


    function _dummy() {}
    set_error_handler('_dummy');


    4) Sign in at posterous.com and click on "Manage" then click on "Autopost" under settings in the left hand column.

    Enter your FlatPress admin username & password then use the following address (yes, it looks strange, but trust me on this one!)

    http://yourdomain/yourflatpressfolder/?xmlrpc.php&rsd

    e&oe

    It needs further testing but I hope I've put all that down correctly.

    ++EDIT August 16th 2010++

    As I continue to get caught out by this - DON'T FORGET to ENABLE the remoteposting plugin in the control panel. I just set up posting via posterous on a new blog over at 110mb.com and got caught out by this easily overlooked step (yet again). But I'm please to report that everything worked perfectly by following the instructions I've given here... once I'd enabled the plugin!
    •  
      CommentAuthorStanley
    • CommentTimeMay 7th 2010
     permalink
    @Bosh

    If you've still got writing to the fp-content/xmlrpc.log file enabled, disable it again and delete your existing log file because when this works properly it will show your FP login/pwd combo to anyone who browses to that file.

    Now, I wonder if you can add categories !?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMay 7th 2010
     permalink
    one last thing, did you try to let posterous to autodiscover the endpoint by pointing just to http://mysite.com/flatpress/ ? the header contains the <link /> tag with the relevant information
    •  
      CommentAuthorStanley
    • CommentTimeMay 8th 2010
     permalink
    Posted By: NoWhereManone last thing, did you try to let posterous to autodiscover the endpoint by pointing just tohttp://mysite.com/flatpress/? the header contains the tag with the relevant information


    I just tried it on another blog using v1.4 of the plugin but with no files altered from their defaults. Posterous accepted the url but it didn't post to the FP blog.

    I then tried the simplest thing which was to uncomment the last 2 lines in defaults.php but that didn't work, so I worked my way back through what I did before and only hit success with the following (just copied from my test post to save time)

    Uncommented the last 2 lines in defaults.php

    Added rsd file to blog root and amended the default setting in the remote
    posting plugin to point to the rsd.xml file. Note that this is not the
    absolute url (as I used in my previous post - no need to do that, just replace the end of the line so it reads rsd.xml),
    url entered into Posterous changed back to /?xmlrpc.php&rsd
    •  
      CommentAuthorStanley
    • CommentTimeMay 8th 2010
     permalink
    Finally, I just tested using Live Writer to post something to that same blog and the good news is that it still worked.

    The only thing which it seems you can't do is add categories, so all your posts sent via Posterous will be unfiled, but I think ease and speed of use far outweigh the fact that I'll need to go in periodically and add a few tags here and there. Posterous does have its own tagging feature, but these tags only show up on your Posterous blog - you simply add them using the syntax ((tag: apple, gadgets)) to your e-mail subject line (including the double parentheses).

    My only concern is that Posterous only give you 1GB of free web space, so they might charge you for more if you reach that limit. Also I read that Posterous are in cahoots with another company who use some javascript to try and add affiliate tags to any suitable links in your post which don't appear to have them already. Well, nothing wrong with them trying to make a bit of money out of this, I suppose.