Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 24th 2009 edited
     permalink
    By popular demand, a Remote Posting plugin, as advertised on the blog

    post via client

    Side note: it is a bit hackish because it was at first designed to work with a new API which I was implementing on my own local FP, and that I still haven't committed since I'm not satisfied.

    I didn't test thoroughly, so bear with me if it won't work (at all) :p

    Wiki page and download

    bye
    •  
      CommentAuthorlantaca
    • CommentTimeJun 27th 2009 edited
     permalink
    When i have to configure live writer, i select WordPress 2.2+ API, but i have to specify the URL for remote posting.
    I have the blog in http://lantaca.altervista.org/index.php, wath URL i have to specify?
    I have digit http://lantaca.altervista.org and i have an error...
    if i digit http://lantaca.altervista.org/fp-plugins/remoteposting/inc/xmlrpc.php i have an error (invalid response document)
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 27th 2009 edited
     permalink
    Yup, you're right, I've re-uploaded the plugin fixed. The entry point should be your website url http://lantaca.altervista.org. By the way, if it works, you shouldn't be asked anymore :)

    have fun!
    •  
      CommentAuthorlantaca
    • CommentTimeJun 28th 2009
     permalink
    when I turn on the plug in( Version 1.1 or 1.0), i can't add a comment at the post.
    Return this error:

    Notice: Only variables should be assigned by reference in /membri2/lantaca/fp-includes/core/core.system.php on line 172

    Notice: Only variables should be assigned by reference in /membri2/lantaca/fp-includes/core/core.system.php on line 174
    XML-RPC server accepts POST requests only.


    If I turn off the plug in, there's no errors.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009
     permalink
    ouch. I didn't think of that. I'll have a look
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009
     permalink
    it's getting a bit hacky-er; by the way, I've uploaded a modified version which should finally work as expected; same place
  1.  permalink
    I tried the plugin with Scribefire (configured correctly and working), buy I have some questions...

    A. When I open Scribefire I get two warning messages:
    1. server error. requested method mt.getCategoryList does not exist.
    2. Il server ha risposto in modo non valido. Verificare la correttezza del blog e dell'API URL. (even if the configuration is correct and working)

    B. Is it right that Scribefire doesn't lists posts and categories, showing me a warning message saying server error. requested method mt.getCategoryList does not exist.?

    Oh, and note (and it's not a critic, but just a note to everyone!) that with scribefire posts published as drafts will be published and not saved in drafts [I think that this is because the feature is not (yet?) implemented] and that the edit timestamp feature doesn't work.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009
     permalink
    well, I have implemented only a subset of the wordpress API (and I don't plan to expand it very much); you can stay with the default (metaweblog API); you'll still get some errors though. I didn't test extensively under ScribeFire; Windows Live Writer allows you to expose a 'manifest' in which you can put the allowed methods, and it works quite fine. I don't know how to do that with other editors at the moment.

    feel free to investigate, or to 'fix' the plugin with the lacking methods.
    •  
      CommentAuthorlantaca
    • CommentTimeJun 29th 2009
     permalink
    Sorry NoWhereMan, i've not undrestand...
    when windows live writer ask me this one

    what path i have to digit here?

    with
    http://lantaca.altervista.org
    or
    http://lantaca.altervista.org/fp-plugins/remoteposting/inc/xmlrpc.php
    don't work
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009
     permalink
    have you downloaded again the plugin from the wiki?
    •  
      CommentAuthorlantaca
    • CommentTimeJun 29th 2009 edited
     permalink
    yes, version 1.2 naw...
    the last error is correct naw, but i don't known how to configure the writer.

    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009 edited
     permalink
    if it works, you shouldn't be asked anymore
    I've found the problem, though, see:

    http://lantaca.altervista.org/?rsd

    PHP is spitting out some garbage; to fix it, put this in your defaults.php

    error_reporting(E_ALL & ~E_NOTICE);
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 29th 2009
     permalink
    version 1.3 uploaded, fixes bugs with categories and recent posts (should fix the scribefire errors).
    made less hackish. the entry point url (if asked) is now http://example.com/flatpress/?xmlrpc

    drafts are NOT supported (no real point in including that, since clients implement drafts on their own)

    enjoy :)
    •  
      CommentAuthorlantaca
    • CommentTimeJun 30th 2009
     permalink
    I'm so sorry, it doesn't work. Same errors on configuration, with version 1.3
    I think it depends on the altervista configuration server
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJun 30th 2009
     permalink
    as I have said, you have to add that line to your defaults.php
    error_reporting(E_ALL & ~E_NOTICE);
    •  
      CommentAuthorlantaca
    • CommentTimeJun 30th 2009 edited
     permalink
    L'ho fatto! :-)
    I've olrady made it, but the problem do not disappear

    (il mio inglese mi ci leva di culo da solo!)
    •  
      CommentAuthoranother
    • CommentTimeJul 7th 2009 edited
     permalink
    I've got the same problem.. using scribfire.. I added the line to my defaults.php , when asked, I specified http://nico202.altervista.org/?xmlrpc (the folder where fp is) but it returns the following error:

    the server responses in an invalid way. check the URL and try again.


    If in the browser I point on http://nico202.altervista.org/?xmlrpc the response is:

    Notice: Only variables should be assigned by reference in /membri/nico202/fp-includes/core/core.system.php on line 172

    Notice: Only variables should be assigned by reference in /membri/nico202/fp-includes/core/core.system.php on line 174
    XML-RPC server accepts POST requests only.


    Hope it can help.
    Thanks
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 7th 2009
     permalink
    add the line I've posted above to your defaults.php
    •  
      CommentAuthoranother
    • CommentTimeJul 7th 2009
     permalink
    maybe I said it in the wrong way.. but when I wrote " I added the line to my defaults.php ", I was just saying that "the line you posted above" IS has been already added to my defaults.php ...
    thx for your work.. everything but that works perfectly
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 7th 2009
     permalink
    sorry I didn't read you did that already, but it's still quite strange. the line I posted suppreses notices, so you can't be having notices in your output. try putting error_reporting(0) and/or post here your defaults.php
    •  
      CommentAuthoranother
    • CommentTimeJul 7th 2009
     permalink
    Here it is the entire defaults.php file:
    <?php

    // defaults.php

    // this file defines standard positions of some important
    // dirs or files.

    // For security reasons
    // these can't be modified in the common settings panels
    // but only through this file.
    // If you want to change these constants, just change
    // the second parameter.

    // We suggest not to define here your owns, but instead
    // inmplementing them as plugins


    // legacy mode; needed with some ill-formed spb files
    define('DUMB_MODE_ENABLED', false);

    // first some webserver setup...
    //here I tried to put one, the other, and both the following two line, without positive results
    error_reporting(E_ALL & ~E_NOTICE);
    error_reporting(0);
    // here's where your server save session-related stuff.
    // If you don't experience any session-related problem, you
    // you can leave it blank and it will default to standard webserver config
    define('SESSION_PATH', '');
    // absolute path to your webserver dir; if you don't experience any problem
    // you can leave this as it is
    define('ABS_PATH', dirname(__FILE__).'/');
    // here was blog root in earlier versions. This has been moved to config_load()


    // here are default config files
    define('FP_DEFAULTS', 'fp-defaults/');


    // all writable directories go here.
    define('FP_CONTENT', 'fp-content/'); //must be chmodded to 0777

    // blog configurations files
    define('CONFIG_DIR', FP_CONTENT . 'config/'); //must be chmodded to 0777
    define('CONFIG_FILE', CONFIG_DIR . 'settings.conf.php');
    define('HASHSALT_FILE', CONFIG_DIR . 'hashsalt.conf.php');
    define('CONFIG_DEFAULT', FP_DEFAULTS. 'settings-defaults.php');
    define('USERS_DIR', FP_CONTENT . 'users/');

    // here we'll store all your entries, comments, static pages and blocks
    // comments are stored automatically in subdirs of the dir CONTENT_DIR
    define('CONTENT_DIR', FP_CONTENT . 'content/');
    //define('BLOCKS_DIR', CONTENT_DIR . 'blocks/');


    // !!! CRITICAL !!!
    // all includes file
    define('FP_INCLUDES', 'fp-includes/');

    // core include scripts
    define('INCLUDES_DIR', FP_INCLUDES . 'core/');
    // smarty engine
    define('SMARTY_DIR', ABS_PATH . FP_INCLUDES . 'smarty/');



    define('FP_INTERFACE', 'fp-interface/');
    // theme dir
    define('THEMES_DIR', FP_INTERFACE . 'themes/');
    // language files
    define('LANG_DIR', FP_INTERFACE . 'lang/');
    // misc forms
    define('SHARED_TPLS', ABS_PATH . FP_INTERFACE . 'sharedtpls/');



    // here is where all plugins are saved
    define('PLUGINS_DIR', 'fp-plugins/');

    define('ADMIN_DIR', 'admin/');


    // cache file name and path.
    define('CACHE_DIR', FP_CONTENT . 'cache/');
    define('CACHE_FILE', '%%cached_list.php');

    define('INDEX_DIR', FP_CONTENT.'index/');

    define('LOCKFILE', FP_CONTENT . '%%setup.lock');


    // these will be probably moved soon to plugins
    // here is where all the uploaded images will be saved
    define('IMAGES_DIR', FP_CONTENT . 'images/');
    // here is where all the attachments will be saved
    define('ATTACHS_DIR', FP_CONTENT . 'attachs/');


    define('LANG_DEFAULT', 'en-us');
    define('BPT_SORT', SORT_DESC);


    set_include_path(ABS_PATH);

    // compatibility with ISS
    if (!isset($_SERVER['REQUEST_URI']))
    $_SERVER['REQUEST_URI'] = 'http://localhost/flatpress/';

    #define('BLOG_ROOT', dirname($_SERVER['PHP_SELF']) . '/');
    define('BLOG_ROOT', ('/'==($v=dirname($_SERVER['SCRIPT_NAME']))? $v : $v.'/') );


    define('BLOG_BASEURL', 'http://'.$_SERVER['HTTP_HOST']. BLOG_ROOT);

    ?>
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 7th 2009
     permalink
    I don't see a reason for it to fail, by the way, try "fixing" the stuff it is complaining about

    in fp-includes/core/core.system.php

    lines 172-174 must be changed from

    $GLOBALS['theme'] =& theme_loadsettings();

    $GLOBALS['lang'] =& lang_load();


    to

    $GLOBALS['theme'] = theme_loadsettings();

    $GLOBALS['lang'] = lang_load();
    •  
      CommentAuthoranother
    • CommentTimeJul 7th 2009
     permalink
    Yeah now it works greatly.. thx a lot
    •  
      CommentAuthorlantaca
    • CommentTimeJul 10th 2009
     permalink
    i'll try this solution and tell you..
    •  
      CommentAuthorlantaca
    • CommentTimeJul 11th 2009
     permalink
    ok, it's work! Thanks
  2.  permalink
    I CANT ENABLE THE SCRIPT?
    •  
      CommentAuthorStanley
    • CommentTimeJul 19th 2009
     permalink
    I got it to work locally by following all the instructions I could find. But I seem to have a problem with the categories not showing up and, if I press the "refresh" button I get an error box up saying

    The server reported an error with the following URL:

    http://[MY_SERVER_NAME]/fp/?xmlrpc

    500 Internal Server Error


    I'll be testing it on a www server soon - as I want to get the picture FTP thing set up, and I don't know how to do that locally though I have all the necessary FTP account set up and waiting for me on the www server.

    I just wondered if anyone else had seen such a message- and could tell me what the problem might be. Everything else works fine - I can post messages but they just go into the "unfiled" category.

    In case this helps anyone - these are the changes I've made so far (all in one easy to follow list)

    Remote Posting Plugin Changes

    a) Installed and enabled plugin.

    b) Follow other instructions at the above link - specifically to allow inline HTML by following these instructions.

    c) Follow additional instructions of
      this forum thread
    - specifically to add the line "error_reporting(E_ALL & ~E_NOTICE);" to the defaults.php, and alter lines 172 to 174 of core.system.php as follows:

    // Rem to enable Windows Live Writer $GLOBALS['theme'] =& theme_loadsettings();

    // Rem to enable Windows Live Writer $GLOBALS['lang'] =& lang_load();

    $GLOBALS['theme'] = theme_loadsettings();

    $GLOBALS['lang'] = lang_load();


    d) Download, install and fire up Windows Live Writer. Make sure the instructions relevant to this stage of the process, as given at the link in (c) are followed, but especially the additonal "?" which is required to be entered in the entry point url, in accordance with this comment in the forum thread referenced in (c)

    e) Make sure that image upload from WLW is enabled. See the instructions on how to do that.
    •  
      CommentAuthorStanley
    • CommentTimeJul 20th 2009
     permalink
    Yayyy!!

    Finally got it working. I tried it with a picture and it came up with an error message, but the post went on my blog ok.

    The error message was

    The response to the metaWeblog.editPost method received from the blog server was invalid:

    Invalid response document returned from XmlRpc server


    Anyone get the same thing, or know how I can suppress the message? It doesn't really matter because it all seems to be working - I'd just like to tidy that up if I can.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 20th 2009
     permalink
    enable FTP uploading if available in your client
    •  
      CommentAuthorStanley
    • CommentTimeJul 21st 2009
     permalink
    Posted By: NoWhereManenable FTP uploading if available in your client


    I narrowed it down - original posts go through without errors. If (in Live Writer) you make a change to your local draft then publish it, it updates the original post on your blog. I think that's a neat and useful thing to be able to do, but that's when you get the error message (even though it still works ok)
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 21st 2009 edited
     permalink
    sounds strange. try killing the warnings with this code in defaults.php
    function _dummy() {} set_error_handler('_dummy');
    •  
      CommentAuthorStanley
    • CommentTimeJul 23rd 2009
     permalink
    Posted By: NoWhereMansounds strange. try killing the warnings with this code in defaults.php
    function _dummy() {} set_error_handler('_dummy');


    That seems to have done the trick. Sorry for the delay - I've been making a set of files customised with all these changes which I can upload to a root folder, go through the setup and run right out of the box. Amazingly, it worked! :)

    Just want to try it out using ScribeFire next.

    Let me know if you want a copy of my changelog and/or the files when I'm done.

    I hope to get a job soon, so I'll send you a donation!

    Thanks again.
    •  
      CommentAuthoremko
    • CommentTimeJul 24th 2009
     permalink
    Hello it's a great plugin. I have just little problem with posting from LiveWriter.
    Whenever I create a new line by enter key, html <p></p> code is posted and it is visible in the blog.
    I use theme SimplaFlex can it be the reason?
    Thanks
    •  
      CommentAuthorStanley
    • CommentTimeJul 24th 2009 edited
     permalink
    Posted By: NoWhereManversion 1.3 uploaded, fixes bugs with categories and recent posts (should fix the scribefire errors).
    made less hackish. the entry point url (if asked) is nowhttp://example.com/flatpress/?xmlrpc


    Just to confirm that this plugin works perfectly with ScribeFire, according to my tests so far. Just make sure that the default Metaweblog API is selected rather than the WP one (SCRIBEFIRE ONLY - WLW users must select WordPress 2.2+), as you previously suggested.

    For those who haven't tried it there are a few important differences between using WLW & SF:

    1) If you first post something using WLW and then you immediately make a small change to your post, while it’s still open in the editing window, WLW will update that same post. ScribeFire, on the other hand, will keep posting new entries by default. To update a post using ScribeFire you first need to select the post you want to update from the list of posts in the “Posts” tab. When you then click on the publish button you are given the option of either updating the original (the default setting in this case) or you can also publish it as a new post.

    2) Also, I wish there was some way to get ScribeFire to nag you to enter a category, if you’ve forgotten to do so, before a post gets published. There's a setting in WLW for this, but I've found no such setting in ScribeFire - and quite a few of my test posts ended up in the unfiled section of my blog.

    3) FTP of images using WLW takes place at the time you publish the posting. In ScribeFire the image is FTP’d to your server as soon as you select it from your file system and click insert; SF uploads the image to your server and THEN displays it in the editor pane. I don't mind this because it means that the final publication of the entry goes through very quickly.

    4) When you use ScribeFire there is an invisible tracking pixel attached to all your posts by default. I didn't like the sond of that, so I turned it off by clicking the settings button to the left of the editor, then selected the “publishing” tab to uncheck the box to disable it.

    In conclusion it looks like I've got both running flawlessly with my blog. I think ScribeFire is so much better for me. On my aging system WLW is far too clunky, and SF makes it easier to post stuff they find on the web, without having to open up WLW to post it. I haven't done any serious comparison of the formatting precision of each - aligning images left of right and getting the text to wrap in all the right places in your published post seems to be a little hit or miss, in both. I'd have thought MS would have got this spot on - but formatting isn't as precise as would be expected of them (chortle!). If SF would only check to make sure that I've remembered to select a category for a post, before it publishes an entry, then it would be nearly ideal.

    The sad thing is, that I'm a loooong time Opera user - and ScribeFire's an Opera-killer for me, unless Opera Unite opens the door to something similar. Or is Opera Unite a blog killer?
    •  
      CommentAuthorStanley
    • CommentTimeJul 24th 2009 edited
     permalink
    Posted By: emkoHello it's a great plugin. I have just little problem with posting from LiveWriter.
    Whenever I create a new line by enter key, html

    code is posted and it is visible in the blog.
    I use theme SimplaFlex can it be the reason?
    Thanks


    Have you tried switching to the default FP theme, and seeing if the problem goes away? I've had no problems switching between the default theme and Deckay 3.0, in case you want to try one of those to see if it really is something in the theme causing the problem, before you go on.

    I've been a bit confused by the way some entries appear in the Admin panel editor - due to different methods of posting being used, and mixtures of HTML & bbcode, etc.

    Just for comparison, and to make sure you have everything correct before you start (and I have no idea if the following has any bearing on your problem, but it's worth checking/correcting these things anyway) :


    1. I have the TinyMCE plugin installed, and the all-in-one zip file of this also contains a fresh copy of the bbcode plugin. I believe there was a syntax error in the "plugin.bbcode.php" file included in the all-in-one distribution. Line 12 has BBCODE_ENABLE_COMMENTS set to "ture". I changed my copy to "TRUE".


    2. Also check that BBCODE_ESCAPE_HTML is set to false in fp-plugins/bbcode/plugin.bbcode.php (appears to be included as Line 11 on the version of that file included in the TinyMCE all-in-one distribution).


    3. I've also got the TinyMCE plugin set as DISABLED in my Admin panel - I like it, but I suspected it was causing some odd behaviour so I turned it off when I started using the Remote Posting plugin.



    Hope this helps.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeJul 24th 2009
     permalink
    Posted By: StanleyJust for comparison, and to make sure you have everything correct before you start (andI have no ideaif the following has any bearing on your problem, but it's worth checking/correcting these things anyway) :[...]
    # Also check that BBCODE_ESCAPE_HTML is set to false in fp-plugins/bbcode/plugin.bbcode.php (appears to be included as Line 11 on the version of that file included in the TinyMCE all-in-one distribution).


    That's the reason.
    •  
      CommentAuthoremko
    • CommentTimeJul 24th 2009
     permalink
    Thank you both, it fixed my problem.
    •  
      CommentAuthorStanley
    • CommentTimeJul 25th 2009
     permalink
    For what it's worth, I reverted BBCODE_USE_EDITOR back to "True" in fp-plugins/bbcode/plugin.bbcode.php as I really missed the image drop down in the BBCode toolbar. I figure most of my WYSIWYG posting will come from Live Writer or ScribeFire now - so I disabled the TinyMCE plugin. But that setting seems to control whether or not your BBCode toolbar shows.

    This makes it show all the time - but it only works when TinyMCE is disabled. I don't mind that for my own use, but it would be nice for it to know when to hide/show itself, according to whether the TinyMCE plugin is active.
    •  
      CommentAuthorhkwanman
    • CommentTimeJul 25th 2009
     permalink
    Get error on posting "\" Symbol :(
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010 edited
     permalink
    Posted By: agentmishrai am using the latest flatpress, simplaflex-red theme, no tinymce, remoteposting enabled.
    as per ur instructions in the above posts, i have made the nessecary changes in the fp-includes/core/core.system.php

    i am getting the same :
    "The response to the metaWeblog.editPost method received from the blog server was invalid:

    Invalid response document returned from XmlRpc server"

    i dont know wat to do, pl guide me


    Is that with ALL posts, or just those where you are trying to include images? Try a text only post and see if it still happens. I had the same error message - it had to do with whether or not you had FTP access to your server (which is needed to upload images with your posts).
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010
     permalink
    I just read back a little - you could try this:

    Change the top of your defaults.php file to look like this

    // defaults.php

    // this file defines standard positions of some important
    // dirs or files.

    // For security reasons
    // these can't be modified in the common settings panels
    // but only through this file.
    // If you want to change these constants, just change
    // the second parameter.

    // We suggest not to define here your owns, but instead
    // inmplementing them as plugins

    // Start of CE v20090722_01 Modifications
    // Added error reporting requirement to enable Windows Live Writer
    error_reporting(E_ALL & ~E_NOTICE);

    // Added function to suppress anomalous error message when UPDATING posts with Windows Live Writer
    // Tested and proven 23/7/09
    function _dummy() {} set_error_handler('_dummy');
    // End of CE v20090722_01 Modifications

    // legacy mode; needed with some ill-formed spb files
    define('DUMB_MODE_ENABLED', false);

    // first some webserver setup...


    etc.

    Try this and report back.
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010 edited
     permalink
    Posted By: agentmishrai have ftp access, but am not posting images

    i am just trying out with live writer, and i get those messages!!!!

    do we get any other tool other than live writer for remote blogging?


    None as good as Live Writer, in my opinion. I got ScribeFire to work with FireFox, and there's a LiveWriter extension or something which Microsoft wrote for that, but I use Opera so I haven't tried it.

    Live Writer should work, it's just a matter of nailing down the problem. It may be something to do with the latest version of the BBCode plugin - I noticed it's changed a little from the one I use.

    Just for kicks try adding this to the top of your plugin.bbcode.php file:

    define('BBCODE_ESCAPE_HTML', false);
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010 edited
     permalink
    Posted By: agentmishrait did some work but now live writer isnt asking for the plugin path, but gives an error that

    http://amitkumarmishra.com/xmlrpc.php not found???

    i believe live writer should ask about the plugin path!


    In Live Writer you need to make sure that you have the entry point shown like:

    http://amitkumarmishra.com/?xmlrpc
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010
     permalink
    Posted By: agentmishrahere's wat i did

    i created a file by the name "xmlrpc.php"
    redirected it tohttp://amitkumarmishra.com/fp-plugins/remoteposting/inc/xmlrpc.php


    after that, when i tried, it gives the same old error

    "The response to the metaWeblog.editPost method received from the blog server was invalid:

    Invalid response document returned from XmlRpc server"


    i checked the bbcode plugin, things are fine

    i just dont understand, wat 2 do?

    sorry i am asking so much 4m u!
    but pl help me!


    There was no need to create such a file, just enter the following entry point in your Live Writer account settings, and it should work:

    http://amitkumarmishra.com/?xmlrpc
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010
     permalink
    Posted By: agentmishrathe settings are being asked just at the livewriter startup, so i am unable to define any extra entry point.
    it asks for my web address for blog -----
    user -----
    password ------


    I would delete the account you've already set up in Live Writer and start over, but read this post first (in this very thread, if you want to scroll up) which shows you the dialogue box you need to watch out for, which is where you need to enter http://amitkumarmishra.com/?xmlrpc

    Your user & password will be your FlatPress blog admin user & password. When you get to wanting to add pictures to your posts then that's when you'll need to use your FTP user/pwd combination, but we'll come to that later.
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010
     permalink
    Posted By: agentmishrahttp://www.flatpress.org/forums/comments.php?DiscussionID=737&page=1#Item_17

    the above is my problem


    Did you try the solution offered there? It worked in that case.

    I'll upgrade to the latest version of Live Writer and try it on a fresh install of the latest version of FP. It may be that there's something new and interesting happening.
    •  
      CommentAuthorStanley
    • CommentTimeJan 24th 2010 edited
     permalink
    Posted By: StanleyI'll upgrade to the latest version of Live Writer and try it on a fresh install of the latest version of FP. It may be that there's something new and interesting happening.


    Posted By: agentmishrai did that, but not working

    i m using portable windows live writer 2009

    link of the same


    http://www.labnol.org/forums/topic/get-windows-live-writer-2009-portable


    I did a fresh install of FP 0.909 then set Live Writer up, and recorded the installation here. It just needed the change I showed above to the defaults.php file making.

    Note that I also installed the Simplaflex Red theme, which is the one you said you were using - though this should work with any theme.

    If you made any other changes to any of the files from the default FP 0.909 installation then you should undo them, then follow these instructions.
    •  
      CommentAuthorStanley
    • CommentTimeJan 25th 2010
     permalink
    Posted By: agentmishrahey buddy, thanks a million

    problem sorted out

    my siteamitkumarmishra.comis accepting remote posts

    i could successfull do it after your help


    Glad to help. Just as an end note - I've since set this up on a couple of other accounts and it was even less painless as Live Writer didn't even ask for the entry point - just the blog address, type of API and user/pwd was all I needed to enter. I've updated my instructions accordingly.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeFeb 13th 2010 edited
     permalink
    FYI : it is now hosted (and updated at) http://flatpress.svn.sf.net/viewvc/flatpress/trunk/extras/fp-plugins/remoteposting/
    new (experimental) feature: file upload!
    •  
      CommentAuthorStanley
    • CommentTimeFeb 16th 2010 edited
     permalink
    Posted By: NoWhereMannew (experimental) feature: file upload!


    "Interim report"
    =============

    I'm looking at it - I'm in the middle of writing a post just now but I'm not sure how to attach/upload anything. I was already using a plugin for Live Writer which lets me select some files then upload them as a zip file, which works quite well. I just don't understand how to attach a file to take advantage of this new feature.

    Also, I'm getting an error message - I'm using the remoteposting plugin from your link above & FP 0.909.1. I must admit I was having trouble installing FP this time around, but I moved to a new hosting provider and may have over-written a file which I'd previously doctored, or else left one in place from my old installation which is stopping it from working. Or it might have something to do with my "slightly experimental" theme. I tried adding the lines to my defaults.php as I'd done before, but that just threw me a 500 internal server error.

    The response to the metaWeblog.newPost method received from the blog server was invalid:

    Invalid response document returned from XmlRpc server


    I'll try this later on a completely fresh installation of FP with the new Remote Posting plugin and report back.