Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

  1.  permalink
    hi there, i can't seem to get the favicon in my blog working... normally there is one preinstalled, isn't there? however i chaged some properties in my css and now there is no favicon... i tried to download the whole flatpress blog-package again and overwrote the folder favicon in fp-plugins.. but it isn't working..due to what???

    i already did a few html pages and when embed a favicon i usually do it this way:
    <link rel="shortcut icon" href="favicon.ico" >
    <link rel="icon" href="favicon.gif" type="image/gif" >


    when i preview the sourcecode of my blog in my browser there is a line which says:

    <link rel="shortcut icon" href="http://bichromatic.at/blog/fp-plugins/favicon/imgs/fplogo.gif" />

    but exactly at that place on the server i can find the fplogo.gif!! and it's even the original one...so it can't be to big or anything..

    does anybody know how i can change that or possibly add the lines mentioned above to the index.php!!!
    •  
      CommentAuthorlaborix
    • CommentTimeJul 29th 2008
     permalink
    Posted By: mathiregisterhowever i chaged some properties in my css and now there is no favicon.

    Hm, try this:

    - clear cache
    - change the used theme to any other and try again

    Then disable the favicon plugin and reload (browser reload) the blog. If nothing will appear, acivate the plugin again, clear cache and cookies in the browser and reload (browser reload) your blog again.

    Please tell what happen...
    •  
      CommentAuthorfelix
    • CommentTimeJul 29th 2008
     permalink
    Maybe this could help?

    http://wiki.flatpress.org/res:plugins:nowhereman:favicon

    I am about to use this myself.
    •  
      CommentAuthorfelix
    • CommentTimeJul 29th 2008 edited
     permalink
    So I was about to use that link I just posted, when I realized there is already a favicon folder in the plugins folder of the new flatpress release.
    So your best option is probably just to upgrade.. It's fairly straightforward from there.


    <?php
    /*
    Plugin Name: FavIcon
    Plugin URI: http://www.flatpress.org/
    Description: Adds a favicon to FlatPress
    Author: NoWhereMan
    Version: 1.0
    Author URI: http://www.nowhereland.it/
    */

    function plugin_favicon_head() {
    echo '<link rel="shortcut icon" href="' . plugin_geturl('favicon') .'imgs/favicon.ico" />';
    }

    add_action('wp_head', 'plugin_favicon_head');

    ?>


    Just modify that imgs/ path to lead to your favicon (aka change the part after it to the name of the file you put in).
    I changed mine to favicon.ico (as above) to cover all my bases on all the browsers.
    If you still have any problems, just clear your cache.
  2.  permalink
    thanks to all, it's working