Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorpam
    • CommentTimeSep 2nd 2010
     permalink
    Ok, I'm only just starting & tried to edit the options in the 'Option' admin control panel and the changes I make don't appear to save.
    (I originally had problems with this page showing errors at the start so I replaced the /admin/panels/config/admin.config.tpl with the version linked to the sticky posting)
    my webpage is www.pamdidthis.co.uk/flatpress
    •  
      CommentAuthorStanley
    • CommentTimeSep 2nd 2010
     permalink
    have you got write permissions on your fp-content/config directory?

    your settings are kept in settings.conf.php in that folder. In my set up I've got the directory set to read/write/execute (CHMOD 777) and that file just as read/write (CHMOD 666). (you could probably change your settings in that file using an editor, if you get stuck, but check your file permissions first)
    •  
      CommentAuthorpam
    • CommentTimeSep 2nd 2010
     permalink
    fp-content/config directory is CHMOD777
    that specific file is CHMOD 666
    •  
      CommentAuthorpam
    • CommentTimeSep 2nd 2010
     permalink
    Yes, i could just edit that file directly, but I'm starting to think that your original point about virgin is right & php just isn't setup right on virginmedia and everything is going to be hard work. After a quick play I've already found a number of small problems e.g. I can't edit a post - the edit button just brings up an empty 'new entry' form. I've added some categories but if I try to add new categories, the category page doesn't show the existing ones.
    I'm sure I can fix each & every one, but if I'm going to struggle at every stage due to Virgin's setup, I'm starting to think that i'd be better off using an external blog app like blogger or wordpress - i was hoping to keep it all on my own webspace but its looking harder & harder.
    •  
      CommentAuthorStanley
    • CommentTimeSep 2nd 2010
     permalink
    www.110mb.com is good and totally free.
    •  
      CommentAuthorpam
    • CommentTimeSep 3rd 2010
     permalink
    oo this is annoying - i've tried debugging the thing but i don't really know php well enough to know what i'm doing or where to start.
    (it took me long enough to setup virgin - i don't want to move elsewhere just yet)
    •  
      CommentAuthorpam
    • CommentTimeSep 5th 2010 edited
     permalink
    Can anyone help me debugging. I tried the 'Show info about PHP' options in the 'Maintain' panel & nothing happens - the maintina panel page just reloads with no phpinfo. Debugging shows that in admin.maintain.php, the section:
    case 'phpinfo': {
    ob_start();
    phpinfo();
    $info = ob_get_contents();
    ob_end_clean();
    $this->smarty->assign('phpinfo', preg_replace('%^.*<body>(.*)</body>.*$%ms', '$1', $info));
    }

    seems to be fine - $this->smarty->_tpl_vars['phpinfo'] is set with all the phpinfo as expected. But nothing gets sent to the screen.
    I can also see that in the tpl file there is a reference to {$phpinfo} but I don't know where the code is that parses the tpl file & replaces the keywords with the values stored in smarty.


    I realise the problem is going to be something about how Virgin has setup php & even if it unsolvable, it would help to understand for any other php scripts I try to install on my website. (It's also teaching me php)

    I'm fairly new to php and would be very greatful for any assistance anyone can give me in debugging this problem.
    Is there an easy way to debug? any log files that can be created?