Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorIgnotus
    • CommentTimeAug 23rd 2010
     permalink
    Hey! I ran into some trouble again..

    I installed the headstuff plugin and uploaded a favicon to my site. Neither the favicon or the headstuff works. It's so messed up that facebook can't recognize any information and won't let me link to the page. I'm using the "ligero" style with my own logo and background, I have practically not even touched the head.tpl.
    Does any of you guys have and idea of what might be wrong?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 23rd 2010
     permalink
    I guess you should just disable headstuff (you can upload an empty version of the plugin file, if you are really in trouble, or edit fp-content/config/plugins.conf.php)
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 23rd 2010
     permalink
    I don't think the fault lies in the headstuff plugin, because disabling it didn't change anything. Perhaps the style had a messed up head from the start? I don't know if you can see what's wrong on the source code, but just in case.. The url is: http://antagonisten.110mb.com
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 24th 2010
     permalink
    your [url=] links are garbled and turned into:
    <a href="\"http://www.dn.se/nyheter/sverige/mobbningsfall-anmals-allt-oftare-1.1157524\"">

    make certain your links look like this: [url=http://... ] without quotes
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 24th 2010
     permalink
    Thank you for pointing that out! Hadn't noticed. I unactivated the Headstuff plugin and tried adding it's content straight into the head.tpl. Atleast the page title changed, but is still not able to link it on facebook. Is it because the head section is cluttered or because it hasn't been indexed yet by search engines?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 24th 2010
     permalink
    see: http://validator.w3.org/check?uri=http://antagonisten.110mb.com/&charset=(detect+automatically)&doctype=Inline&group=0

    also you DON'T change the TITLE by adding it to the header, you change it from the "blog title" setting in the option admin panel
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 24th 2010
     permalink
    I restored the header.tpl to the original and replaced the tags with the xhtml compatible tags. Now it's fully validated by w3. Still the favicon won't work and is unable to even paste my link on facebook. Does the site have to be indexed first by serchengines or what? I can't make any sense of this =S
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 24th 2010
     permalink
    Still the favicon won't work


    use the favicon plugin (bundled) and customize the path in fp-plugins/favicon/plugin.favicon.php to fit your need. (put the image in fp-plugins/favicon/imgs)

    is unable to even paste my link on facebook.


    what do you mean exactly? sometimes the facebook note import tool just won't work, I can say it from my own experience. You might want to try the fb app rss graffiti :)
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 24th 2010
     permalink
    Hmm.. Almost feel like giving up on the favicon. I replaced the image in /imgs early on, cleansed the cache (just to be sure) and still it didn't show. So I edited the plugin file like you suggested and just wrote the full path to the image. Still nothing.

    I haven't installed a "share on Facebook" icon if that's what you're getting at. I just tried to post a message on my wall with the link. But it just transforms into "(No title)" and blocks me from posting. Anyway, i'd like to say that I appreciate you investing time in this.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 25th 2010
     permalink
    unfortunately I can't say at the moment :/ I've just tried and you are right...
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 30th 2010 edited
     permalink
    Recently I've been thinking. It has to do something with the header information. So perhaps it's connected to some other errors I'm having?
    When I change the language I get this error:

    Warning: Cannot modify header information - headers already sent by
    (output started at /www/110mb.com/a/n/t/a/g/o/n/i/antagonisten/htdocs/fp-interface/lang/sv-sv/lang.conf.php:1)
    in /www/110mb.com/a/n/t/a/g/o/n/i/antagonisten/htdocs/fp-includes/core/core.wp-pluggable-funcs.php on line 273


    I disregarded that warning earlier because when I press backwards in the page history it says "changes saved". Perhaps there's somthing on line 273 that causes the problems i'm currently having?
    •  
      CommentAuthorlantaca
    • CommentTimeAug 31st 2010
     permalink
    the favicon plugin doesn't work with microsoft IE, any version. :-)
    •  
      CommentAuthorpierovdfn
    • CommentTimeAug 31st 2010
     permalink
    Posted By: lantacathe favicon plugin doesn't work with microsoft IE, any version. :-)

    IE is bugged: Favicon works, but you have to add the page to the bookmarks to see the favicon :-)
    •  
      CommentAuthorlantaca
    • CommentTimeAug 31st 2010
     permalink
    you have to add the page to the bookmarks to see the favicon

    in my IE8 on windows XP sp3 doesn't appears, i see only the standar favicon of windows (a little blu "e")
    •  
      CommentAuthorNoWhereMan
    • CommentTimeSep 1st 2010
     permalink
    After a while, I had an idea: the file, wherever it is, must be named favicon.ext, where ext is ico (if it is a ICO file), or gif, png... etc.

    I have committed the change to SVN, it should now work in IE8, please check it! :)
    •  
      CommentAuthorlantaca
    • CommentTimeSep 1st 2010
     permalink
    If i put the favicon.ico file on my server, i see the favicon with IE, with favicon plugin disable too (this way works allways)

    if i rename an image to favicon.ext and put it in the imgs folder of plugin folder, then cange the plugin to see these file, i never see the favicon with any browser.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeSep 1st 2010
     permalink
    Posted By: lantacaif i rename an image to favicon.ext and put it in the imgs folder of plugin folder, then cange the plugin to see these file, i never see the favicon with any browser.


    I've committed the change to SVN... I guess you HAVE to use a favicon.ico file...
    •  
      CommentAuthorIgnotus
    • CommentTimeSep 5th 2010
     permalink
    Indeed. It works in Firefox!