Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorIgnotus
    • CommentTimeAug 19th 2010
     permalink
    Hello!

    As you probably have figured out, I tried to install a language pack but without success. It just won't appear in the list under Options. My FP installation is of the latest version, but the language pack is from version 0.804. Also I installed FP first and uploaded the language files later. So - Does anyone have any idea what I have to do to get this to work?
    •  
      CommentAuthorChrisBlank
    • CommentTimeAug 20th 2010
     permalink
    Have you check the dirctory?
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 20th 2010
     permalink
    Have I checked what in the directory?
    •  
      CommentAuthorfabrix
    • CommentTimeAug 20th 2010
     permalink
    in folder fp-interface/lang/ should be a directory named after the language code you installed, whit serveral .php files in it, like de default fp-interface/lang/en-us/
    make sure is readable by the web server
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 20th 2010 edited
     permalink
    In "fp-interface/lang" I've placed my language files in a folder named "sv". So there is two folder, sv and eng-us. Should the "sv" folder be placed inside eng-us?
    •  
      CommentAuthorlaborix
    • CommentTimeAug 20th 2010 edited
     permalink
    Take this steps:

    Rename the fp-interface/lang/sv to "sv-sv", then open an editor (local) and edit the language file "lang.conf.php".

    Replace
    line: 5 - $langconf['locale'] = 'sv';
    with
    line: 5 - $langconf['locale'] = 'sv-sv';

    Save this file and transfer it back to fp-interface/lang/sv-sv. Overwrite the existing file and login, go to admin panel, there to Options and try again.

    It seems that Flatpress won't work only with "sv" (Tested on SVN 341 and it work).
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 22nd 2010
     permalink
    I just saw your answer and tried it. Thank you! Now it appears in the list. But - I ran into another problem. Even though it's utf-8 encoding the ä, å, ö characters dosen't seem to work. Do I have to go through all the files and add alt-codes for the characters or is there some quick fix?
    •  
      CommentAuthorlaborix
    • CommentTimeAug 22nd 2010 edited
     permalink
    A quick fix? No, but try these steps: Open PSPad / Notepad++ / or one other editor which can handle UTF-8 files.

    Open a new file, check UTF-8 encoding
    Open the first language file, mark all, copy and paste it to the new file, save as UTF-8.

    Do this with all other language files, but take care, save as UTF-8. Transfer they back to your webspace and try it out...
    •  
      CommentAuthorIgnotus
    • CommentTimeAug 22nd 2010
     permalink
    That worked. Thank you, I really appreciate it.