Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorlaborix
    • CommentTimeAug 19th 2010
     permalink
    Details:
    Apache 1.3, PHP 5.2.14 and SVN 341 (new and clean setup), no PrettyUrls active.

    If you click on "readmore" in the "Welcome to Flatpress" entry (default entry), this entry will work like expected, but at top you see:
    Notice: WALKER: Not a valid index (0) in D:\www\htdocs\flatpress\fp-includes\core\core.bplustree.class.php on line 2458

    If you have the calendar plugin active, at top of your sidebar (widget), so you didn't see the calendar anymore. The next widget will displayed correct and all others, but the first is invisible?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 19th 2010
     permalink
    If you have the calendar plugin active, at top of your sidebar (widget), so you didn't see the calendar anymore. The next widget will displayed correct and all others, but the first is invisible?


    it is a side effect of the notice; the notice shouldn't show up I'll investigate...
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 19th 2010
     permalink
    I can't reproduce your problem :S
    •  
      CommentAuthorlaborix
    • CommentTimeAug 19th 2010 edited
     permalink
    Hm, really curios..., I set up a complete new svn 341 and get this notice again. But...

    I get this notice only on one subdomain. If I setup svn 341 new on the same server, but not on this subdomain, there no notice appears. It seems, that there is a problem with the subdomain (.htaccess routing?) from my provider. All other things work, it only appears if I click on readmore.

    Ok, quick test. It only appears with the original setup entry. If I write a new entry and use then the readmore plugin, all work fine. No notice. If I now test the original flatpress setup posting, it also work fine. No notice appear. At the time, if I set up a complete new flatpress, the notice will came up.

    I will try more ...
    •  
      CommentAuthorlaborix
    • CommentTimeAug 22nd 2010 edited
     permalink
    Here some results (Apache and PHP 5.2.14):

    I set up SVN 341 more times in different directories, with different access rights (0x755 and 0x777), clearing cache after setup, clearing browser cache and using different browsers for setup. But on my webspace (1&1 provider) I get this notice, whatever I do :(

    Notice: WALKER: Not a valid index (0) in /.../htdocs/flatpress/fp-includes/core/core.bplustree.class.php on line 2458

    If I add a new entry, with or without readmore, all work fine. No more notice came up. Only the first by setup gernerated entry will fail after clicking readmore. The whole entry will displayed correct, but with the notice.

    After that, I setup SVN 341 on IIS 7.0 with PHP 5.2.14. And?.. Whow, all work fine after setup.

    Now I really don't know what's going wrong by my 1&1 provider.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 22nd 2010
     permalink
    ok, I had notices disabled, I can see the error too, now. I'm having a look.
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 22nd 2010
     permalink
    check r342 :)

    Modified : fp-includes/core/core.fpdb.class.php
    •  
      CommentAuthorlaborix
    • CommentTimeAug 22nd 2010
     permalink
    Thanks, readmore work...