Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorGreenMap
    • CommentTimeAug 14th 2010
     permalink
    something curious caught my eye this morning:
    our blog at greenmap-berlin.de
    went blind constituting the right date: e.g. today is Saturday, the 14. of August, ok:

    UTC Zeitzone
    Sat, 14 Aug 2010 14:24:2


    But it does mean, it's Sunday!

    Ausgabe: Sonntag, 14. August 2010

    Ups.

    what's gotten into it - may this fault possibly belong to the plugin "DateChanger" or ...?
    I can't imagine

    cheers!
    •  
      CommentAuthorNoWhereMan
    • CommentTimeAug 14th 2010
     permalink
    My guess is that the lang file is wrong: switch to English and check if the problem is still there; if it's not, fix the lang.default.php file (you might have an outdated lang file, download the last version from our wiki
    •  
      CommentAuthorlaborix
    • CommentTimeAug 14th 2010
     permalink
    Hi GreenMap,

    go to admin panel, in the tab options, you can set the default time zone. Try to change it there. Also it is possible, that your server has the wrong time zone or is placed outside Europe, but I think after looking to your site with the calendar plugin (modified?), that your time zone should be ok.

    I don't think there is a problem with the datechanger plugin, it works without any bugs on 0.909.1 and SVN 337. Ok, it is possible, as I said above, that your server has a wrong time zone.
    •  
      CommentAuthorGreenMap
    • CommentTimeAug 14th 2010 edited
     permalink
    ... some things should be so easy but i didn't thought for this.
    NoWhereMan, you are right!

    i did switch to English and all was ok:

    UTC time is
    Sat, 14 Aug 2010 17:34:51 +0200
    Time should differ by
    hours
    Default format for date

    Output: Saturday, 14. August 2


    so i will look for this lang file immediately.

    @laborix
    yes, i'd tried to modifiy the calendar plugin, so it will shoe the current day, but it won't work... - wonder you did find that out! ;-)

    ---

    the "phpinfo" says:

    Calendar
    Calendar support enabled

    ...

    date

    date/time support enabled
    Timezone Database Version 0.system
    Timezone Database internal
    Default timezone System/Localtime

    Directive Local Value Master Value
    date.default_latitude 31.7667 31.7667
    date.default_longitude 35.2333 35.2333
    date.sunrise_zenith 90.583333 90.583333
    date.sunset_zenith 90.583333 90.583333


    but:

    date.timezone no value no value

    but will not matter ...

    the datechanger plugin does work well, it has been an misapprehension.

    and all other i hope, when i change the lang file!


    thank you both,
    nice WE!

    #Edit
    hmm ...
    the lang.default.php does look uptodate ... (i think i remember, i did the actual version onto the installation)
    the weekdays are named correctly in german.
    should be another cause or do i go now completely wrong?
    i will search for this into those lang-files ...
    •  
      CommentAuthorlaborix
    • CommentTimeAug 15th 2010
     permalink
    Posted By: GreenMap@laborix
    yes, i'd tried to modifiy the calendar plugin, so it will shoe the current day, but it won't work... - wonder you did find that out! ;-) ...

    The original calendar plugins use three characters for the weekday and the week start with Sunday.

    Posted By: GreenMap... the lang.default.php does look uptodate ... (i think i remember, i did the actual version onto the installation)
    the weekdays are named correctly in german. ...

    I'm not sure, all versions it tested, work correct with Apache and IIS. Ok, these servers are localizied in germany and use as time zone "Amsterdam, Berlin...".

    Can you set up a new Flatpress installation on your server in a hidden directory to find out if it work with a default installation? After that add the german language pack and try again.