Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorrennox
    • CommentTimeApr 1st 2010
     permalink
    After completing the fields on the setup page I get the following error at the top of the 'End of Story' page:

    <code>Warning: rename(fp-content/content/drafts/entry100401-165632.txt,fp-content/content/10/04/entry100401-165632.txt) [function.rename]: Permission denied in C:\Inetpub\vhosts\fisherslaw.co.uk\httpdocs\flatpress\fp-includes\core\core.entry.php on line 818

    Warning: unlink(fp-content/settingup.lock) [function.unlink]: Permission denied in C:\Inetpub\vhosts\fisherslaw.co.uk\httpdocs\flatpress\fp-includes\core\core.filesystem.php on line 146</code>

    If I then click log-in I get:

    <code>Warning: Smarty::include(fp-content/cache/\e93fccb09cf8b04111b9595da102f3f4^%%3A^3A6^3A66F9CF%%default.tpl.php) [function.Smarty-include]: failed to open stream: No such file or directory in C:\Inetpub\vhosts\fisherslaw.co.uk\httpdocs\flatpress\fp-includes\smarty\Smarty.class.php on line 1258

    Warning: Smarty::include() [function.include]: Failed opening 'fp-content/cache/\e93fccb09cf8b04111b9595da102f3f4^%%3A^3A6^3A66F9CF%%default.tpl.php' for inclusion (include_path='C:\Inetpub\vhosts\fisherslaw.co.uk\httpdocs\flatpress/') in C:\Inetpub\vhosts\fisherslaw.co.uk\httpdocs\flatpress\fp-includes\smarty\Smarty.class.php on line 1258</code>

    What has gone wrong?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeApr 1st 2010
     permalink
    sounds a lot like this problem: http://www.flatpress.org/forums/comments.php?DiscussionID=961

    is your server running that SuPHP thing?
    •  
      CommentAuthorrennox
    • CommentTimeApr 1st 2010
     permalink
    I don't think so, originally I couldn't write to the fp-content folder and so couldn't get past the first page of setup. I asked my host to change permissions to '777', they came back to me to say it had been done (no mention of any security problem with 777). I was then able to continue to enter a user name etc. but then get this error.

    On setup the URL field is defaulting to 'mysite.co.uk/flatpress/', this is the folder in my root but do I need to choose an actual php page?
    •  
      CommentAuthorNoWhereMan
    • CommentTimeApr 1st 2010
     permalink
    maybe Safe Mode is enabled ? you see, it looks like you are having problems with file permissions; I'd assume it's something to do with your webserver config :/