Not signed in ( Sign In)

Categories

Welcome, Guest

Want to take part in these discussions? Sign in if you have an account, or apply for one below

Vanilla 1.1.10 is a product of Lussumo. More Information: Documentation, Community Support.

    •  
      CommentAuthorsvennid
    • CommentTimeMar 7th 2010 edited
     permalink
    hi,

    i use the latest version of flatpress and i tried to use comments but the following message appears:

    "Deprecated: Assigning the return value of new by reference is deprecated in /Library/WebServer/Documents/comments.php on line 218"

    but i see the comment field but without name, email address, website and so. if i click on send this message appears:

    Deprecated: Assigning the return value of new by reference is deprecated in /Library/WebServer/Documents/comments.php on line 218

    Warning: Cannot modify header information - headers already sent by (output started at /Library/WebServer/Documents/comments.php:218) in /Library/WebServer/Documents/fp-includes/core/core.wp-pluggable-funcs.php on line 273

    the comment is shown correctly if i reload the site. would be thankful for any help! ;-) btw: i run flatpress on a mac mini with snow leopard (not the server version) with the lastest patch (PHP Version 5.3.0, Apache v2.2.13)

    best regards sven
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMar 7th 2010
     permalink
    either delete the & from =& on line 218 of comments.php or uncomment the last two lines of defaults.php

    function _dummy() {}
    set_error_handler('_dummy');

    to suppress (boring) warnings.
    •  
      CommentAuthorsvennid
    • CommentTimeMar 7th 2010 edited
     permalink
    Posted By: NoWhereManeither delete the & from =& on line 218 of comments.php or uncomment the last two lines of defaults.php

    function _dummy() {}
    set_error_handler('_dummy');

    to suppress (boring) warnings.


    thank you! works great - is this a bug or so?

    sven
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMar 7th 2010
     permalink
    it's not really a bug, it is a deprecated syntax from PHP4 which makes PHP5 throw an unsuppressable warning; it's fixed in SVN, by the way.
    •  
      CommentAuthorsvennid
    • CommentTimeMar 9th 2010
     permalink
    Hi NoWhereMan,

    the problem isn't fix yet :-(

    when i click on submit, the following error messager appears ...

    Warning: Parameter 1 to plugin_qspam_validate() expected to be a reference, value given in /Library/WebServer/Documents/fp-includes/core/core.wp-plugin-interface.php on line 54


    hope you can help me again ... btw: is the latest svn a stable release?


    best regards sven
    •  
      CommentAuthorlaborix
    • CommentTimeMar 9th 2010 edited
     permalink
    Posted By: svennidhope you can help me again ...

    I'm not sure, but do you have FP 0.909.1? If so, please read this forum entry and download the two listed files.
    To the Flatpress Forum entry...

    btw: is the latest svn a stable release?

    No, svn isn't a stable version, but you can use it at your own risk ( for me it works on Apache and IIS ;) )
    •  
      CommentAuthorNoWhereMan
    • CommentTimeMar 9th 2010
     permalink
    uncomment the error handler in defaults.php and enjoy your error-free user experience
    •  
      CommentAuthorsvennid
    • CommentTimeMar 10th 2010
     permalink
    Posted By: laborixI'm not sure, but do you have FP 0.909.1? If so, please read this forum entry and download the two listed files.


    yes - thank you, works perfectly! i wanna see the errors for fixing them ;-) it's like homer simpson and the car's engine lamp :-D

    sven